Installare vmware tools su Openfiler virtuale

Postato il Aggiornato il

Ed ecco un altro post, dopo quello precedente su smoothwall, che riguarda l’installazione dei vmware tools su un’altra distribuzione linux, sottoposta ad hardening come la, ormai a me cara, Openfiler, che viene spesso virtualizzata all’interno di vmware vSphere con la funzione di storage iscsi condiviso.
Occorre che openfiler sia aggiornato all’ultima patch e sarà necessario scaricare e installare un compilatore gcc (compilatore C) per la corretta compilazione dei tools.

Dopo aver installato openfiler come guest virtual machine di vmware vSphere 4.1 entrate in console con l’utente root e lanciate l’aggiornamento con il comando:

conary updateall

Una volta terminato l’aggiornamento lanciare l’installazione del compilatore C con il comando:

conary update gcc

Riavviare la macchina virtuale.
Dal vClient lanciare l’installazione dei vmware tools che verranno montati sul cdrom virtuale.

Ora occore montare su openfiler i vmware tools ed eseguiamo:

  1. mkdir /dev/cd
  2. mount /dev/cdrom /mnt/cd

Verifichiamo il contenuto della cartella con il comando:

  1. cd /mnt/cd
  2. ls

e troveremo il pacchetto dei vmware tools:

Copiamo i vmware tools nella directory “tmp” per lanciare poi l’installazione vera e propria:

cp VMwareTools-x.x.x.xxxxx.tar.gz /tmp

Digitare i seguenti comandi:

cd /tmp
tar zxvf VMwareTools-x.x.x.xxxxx.tar.gz
cd vmware-tools-distrib
. /vmware-install.pl

Premere sempre invio ad ogni domanda accettando così i percorsi di default proposti.

Ora dal vClient i vmware tools risultano correttamente installati e funzionanti:

IZ

 

3 pensieri riguardo “Installare vmware tools su Openfiler virtuale

    vince ha detto:
    30/07/2012 alle 17:08

    ciao Ivan, purtroppo restituisce questo errore:
    Error occurred opening repository http://openfileresa.rpath.org/conary/: Temporary failure in name resolution

    quando si fa: conary updateall intendo …..

      Ivan Zini ha risposto:
      30/07/2012 alle 21:55

      Ciao,
      prova a dare i seguenti comandi in console o tramite ssh

      conary sync group-openfileresa-appliance
      conary updateall –keep-required

      IZ

    vince ha detto:
    30/07/2012 alle 17:09

    si scusa dimenticavo sulla 2.99

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...